24 lines
482 B
Nix
24 lines
482 B
Nix
{ description = "My collection of flake templates";
|
|
outputs = { self }: {
|
|
templates = {
|
|
|
|
latex = {
|
|
path = ./latex;
|
|
description = "A fairly basic latex flake";
|
|
};
|
|
|
|
trivial = {
|
|
path = ./trivial;
|
|
description = "What I consider to be the bare minimum flake";
|
|
};
|
|
|
|
haskell = {
|
|
path = ./haskell;
|
|
description = "A basic Haskell flake";
|
|
};
|
|
|
|
};
|
|
defaultTemplate = self.templates.trivial;
|
|
};
|
|
}
|