voidconf/modules/kernel.nix
2024-02-17 18:49:37 +01:00

18 lines
389 B
Nix

{ lib, config, ... }:
with lib;
let cfg = config.voidconf.kernelTweaks;
in {
options.voidconf.kernelTweaks = {
enable = mkEnableOption "Enables kernel tweaks";
};
config = mkIf cfg.enable {
boot = {
kernelModules = [ "tcp_bbr" ];
kernel.sysctl = {
"net.ipv4.tcp_congestion_control" = "bbr";
"net.core.default_qdisc" = "fq";
};
};
};
}