voidconf/modules/fcitx5.nix
2024-06-02 08:09:14 +02:00

22 lines
443 B
Nix

{ lib, config, pkgs, ... }:
with lib;
let cfg = config.voidconf.fcitx5;
in {
options.voidconf.fcitx5 = {
enable = mkEnableOption "Enables fcitx5 input method engine and mozc en anthy methods";
};
config = mkIf cfg.enable {
i18n = {
inputMethod = {
enabled = "fcitx5";
fcitx5 = {
addons = with pkgs; [
fcitx5-mozc
fcitx5-anthy
];
};
};
};
};
}